Calc posee numerosas funciones para trabajar con textos. Entre las más usadas están estas:
=IGUAL(“texto1”; “texto2”): Compara dos cadenas de texto, devuelve VERDADERO si las cadenas son exactamente iguales y FALSO si no lo son. Esta función distingue entre mayúsculas y minúsculas.
Ejemplos:
     =IGUAL(“Calc”; “Calc”) devuelve VERDADERO
     =IGUAL(“Calc”; “calc”) devuelve FALSO
texto1
texto2
=CONCATENAR(“texto1”; “texto2”; …; “texto30”): Concatena varias cadenas de caracteres en una sola. Esta función es equivalente al operador “&”.
Ejemplo:
    =CONCATENAR(“Hola”; “ “; “mundo”) devuelve Hola mundo
texto3

Continúa leyendo

Un informe es un documento de texto que muestra los datos almacenados en una tabla o consulta.

Igual que en los casos anteriores también podemos crear los informes de forma manual o mediante un asistente. El asistente nos guiará paso a paso a través del proceso de creación del informe. En el panel izquierdo de la ventana de Base de datos, haga clic en el icono Informes. A continuación haga clic en Usar el asistente para crear un informe…

base21Selección de campo. Comenzamos especificando la Tabla o consulta sobre la que se creará el informe. Del mismo modo como vimos antes para los formularios y las consultas agregaremos los campos que queramos que aparezcan.

base22Etiquetar campos. El nombre de los campos puede ser bastante críptico. Por ello puede especificar una etiqueta más legible para cada uno de ellos y será así como aparezcan en el informe. Es similar a los “alias” de las consultas.

base23Agrupación. Los registros se pueden agrupar a partir de los valores de uno o más campos. Seleccione los campos por los que agrupar el informe resultante.

base24Opciones de ordenación. Seleccione el orden en que se deben mostrar los campos en el informe.

base25Selección del diseño. Configuramos el aspecto del informe mediante la disposición de los datos, cabeceras y pies del informe.

base26Crear informe. Un Informe estático mostrará los datos que hubiera en las tablas o consultas en el momento de su creación. En cambio un Informe dinámico será actualizado automáticamente cada vez que se introduzcan nuevos datos. Indique también si desea crear el informe inmediatamente o modificar su diseño.

 

Básicamente, las consultas sirven para obtener información recogida en una base de datos. En ocasiones la base puede contener más información de la que se necesita en un momento dado y nos interesa filtrar dicha información de modo que se adapte a lo que andamos buscando. Igual que en los casos anteriores también podemos crear las consultas de forma manual o mediante un asistente.

base16Selección de campo. Indicaremos los campos que se utilizarán para la consulta, descartando, por tanto, el resto de la información de la(s) tabla(s).

base17Orden de clasificación. Indicamos aquí el criterio que servirá para la clasificación y el orden en que se mostrarán, ascendente o descendente, los registros consultados.

base18Condiciones de búsqueda. Especificamos los campos y condiciones que han de servir para realizar el filtrado de la base de datos. De no imponer ninguna, se mostrarán todos los registros agrupados según le indiquemos al asistente.

base19Alias. Si nos interesa sustituir en nombre del campo por alguna otra palabra en el resultado de la consulta.

base20Información general. Es el último paso del asistente y contiene un resumen de todos los pasos que hemos dado. Como en los casos anteriores podemos decidir si mostrarnos la consulta que hemos creado o abrirlo en el modo de diseño para realizar algunos ajustes. Daremos un nombre a esta consulta, dado que se pueden definir múltiples consultas de la misma base de datos para cubrir distintas necesidades de información. Comprobamos que todo es correcto y pulsamos en Finalizar.

Los formularios tienen como finalidad el poder introducir o modificar fácilmente el contenido de la base de datos. Para crearlos, al igual que en los casos anteriores, podemos utilizar dos métodos: uno manual llamado Modo de diseño y otro mediante un Asistente, que es la opción más recomendable cuando no se conoce a fondo el funcionamiento de este programa.

base10Selección de campo. Desde aquí seleccionaremos los campos que queremos que aparezcan en el formulario, normalmente serán todos, si necesitamos controlar todos los datos de cada registro, excepto el campo ID (campo de clave principal) que lo gestiona automáticamente la base.

base11Configurar un subformulario. Un subformulario es un formulario que se inserta en otro formulario. Este paso nos permitirá decidir si queremos utilizar un subformulario y configurar sus propiedades. Si no queremos un subformulario pasaremos directamente al paso siguiente.

base12Organizar campos de control. Aquí definimos la forma en que se visualizará el formulario pudiendo ser en bloques, columnas, como hoja de datos, etc. Esta cuestión afecta únicamente a la presentación, no a la naturaleza de los datos.

base13Establecer entrada de datos. Desde aquí especificaremos el modo como se controlará la entrada de datos para el formulario. Es en sí mismo bastante explicativo.

base14Aplicar estilos. En esta pantalla aplicamos estilos y bordes de campo al formulario en su vertiente meramente estética.

base15Establecer nombre. Ahora pondremos el nombre al formulario e indicaremos si queremos empezar a trabajar con él o modificar la ubicación de los campos en función a nuestras necesidades o gustos. Recordemos que se pueden definir múltiples formularios para la misma tabla de datos.

Podemos crear una tabla manualmente mediante el modo de diseño o utilizando el asistente. Veamos este segundo método que, a menudo, es el más sencillo y rápido.

Haga clic en Tablas bajo la columna Bases de datos. Seguidamente en la columna Tareas pulse en Usar el asistente para crear una tabla…

base05El asistente contiene una colección de tablas de muestra categorizadas donde, probablemente, encontraremos alguna que se ajustará a nuestras necesidades con algún leve retoque.

base06A modo de ejemplo constuiremos una simple tabla para almacenar las direcciones de nuestos contactos.

Desde Seleccionar campos indicamos aquellos que nos interesan, aunque podríamos elegirlos todos o incluir alguno posterioremente en caso necesario. Hecho esto pulsamos el botón Siguiente.

base07Establecer tipos y formatos. Ahora tendremos que establecer los valores para cada uno de los campos. También podemos añadir campos nuevos pulsando el botón marcado con +. Hecho esto pulsamos el botón Siguiente.

base08Establecer clave principal. La clave principal es un identificador único para cada registro de la tabla y es sobre todo útil cuando hay varias tablas vinculadas. Lo mejor, si no sabe muy bien qué está haciendo, es dejar que el asistente la cree automáticamente. Terminado esto pulsamos el botón Siguiente.

base09Crear tabla. Ahora daremos un nombre a la tabla e indicamos qué queremos hacer a continuación:

  • Insertar datos inmediatamente. Se nos abrirá la tabla para comenzar con la introducción de datos.
  • Modificar el diseño de la tabla. La tabla se abre en modo de diseño y podemos realizar todas las modificaciones que queramos. Esta función es sobre todo para usuarios que conozcan bien cómo funciona una base de datos.
  • Crear un formulario basado en esta tabla. Nos permitirá crear un formulario que facilite la introducción de datos en la tabla.

LibreOffice Base es capaz de manejar diversos formatos de archivo de bases de datos, como Access o dBase y también conectarse a bases relacionales externas como MySQL, PostgreSQL u Oracle. Y todo ello con la ayuda de un asistente que simplificará mucho el trabajo del usuario.

Para crear un archivo de base de datos, ejecutamos LibreOffice Base, o bien desde cualquiera de los componentes de LibreOffice desde Archivo->Nuevo->Base de datos. En cualquier caso se nos abrirá el Asistente de bases de datos que nos permitirá crear fácilmente una base de datos.

base01En la primera pantalla del Asistente para bases de datos, seleccionaremos lo que queremos hacer (Crear una base de datos nueva, Abrir una base de datos existente o Conectar con una base de datos existente) y pulsaremos sobre el botón Siguiente.

base02Seguidamente se nos preguntará si deseamos registrar la base de datos y, una vez guardado el archivo, qué queremos hacer con él, abrirlo para editarlo y/o crear tablas usando el asistente. Una vez marcadas las opciones que nos interesen pulsaremos sobre Finalizar.

base03Le damos ahora nombre al archivo, seleccionamos la capeta donde se guardará y pulsaremos sobre Guardar.

base04Una vez realizado el proceso anterior se nos abrirá una ventana con la nueva base de datos creada. Desde aquí podemos ver y crear todos los elementos de la base: Tablas, Consultas, Formularios e Informes.

Suele ocurrir que, en ocasiones, en la celda donde se esperaba obtener el valor resultante de determinado cálculo, se obtiene un extraño mensaje, casi incomprensible, con todas las letras en mayúsculas, que comienza con el signo “#” y que termina con un signo de exclamación “!” o, en otros casos, con un signo de interrogación “?” A este mensaje se le llama código de error. Su misión consiste en informar de que se ha producido en error en la fórmula o función utilizada, ya sea en la propia formula o en alguna celda a la que hace referencia dicha fórmula.
Después de que un código de error aparezca en una celda, se tiene que descubrir qué causó el error y editar la fórmula para poder continuar.
Estos son los códigos de error más habituales en Calc:
 

#¡DIV/0! Aparece cuando en la fórmula existe una división por cero o, como suele suceder habitualmente, la celda por la que hay que dividir no contiene ningún valor. Algunas otras funciones devolveran este error, por ejemplo:

  • VARP con menos que 1 argumento
  • STDEVP con menos de 1 argumento
  • VAR con menos de 2 argumentos
  • DESVEST con menos de 2 argumentos
  • STANDARDIZE con stdev=0
  • NORMDIST con stdev=0

#¿NOMBRE? Aparece cuando la fórmula se refiere a un nombre de rango que no existe en la hoja de trabajo. Este valor de error aparece cuando no se ha podido evaluar un identificador; por ejemplo, no hay referencia válida, nombre de dominio válido, etiqueta de columna/fila, macro, separador de decimales incorrecto, no se ha encontrado add-in.

#¡NUM! Aparece cuando Calc encuentra un problema con un número en la fórmula usada, tal como el tipo equivocado de argumento o un cálculo que produce un número demasiado grande o demasiado pequeño para ser representado en la hoja de trabajo.

#¡REF! Indica que Calc ha encontrado una referencia no válida a una celda, como cuando se elimina una celda a la que se hace referencia en la fórmula.

#¡VALOR! Señala que se ha utilizado un tipo incorrecto de argumento o cuando una celda que está referenciada dentro de una fórmula contiene texto en vez de un número.

Calc dispone de varias funciones para redondear números, con el uso de estas funciones se consigue que el resultado de una operación numérica aparezca con el formato deseado.

ENTERO(número): Redondea a la baja al entero más próximo.
Ejemplos:
=ENTERO(10,58) devuelve 10
=ENTERO(-3,36) devuelve -4

redondear1
REDONDEAR(número; número_de_decimales): Redondea un número hasta una cantidad determinada de decimales.
Ejemplos:
=REDONDEAR(6,35; 1) devuelve 6,4
=REDONDEAR(6,55; 1) devuelve 6,6
=REDONDEAR(6,35; 0) devuelve 6
=REDONDEAR(6,75; 0) devuelve 7

=REDONDEAR(2,348; 2) devuelve 2,35
=REDONDEAR(2,348; 0) devuelve 2
=REDONDEAR(2,5) devuelve 3
=REDONDEAR(987,65; -2) devuelve 1000

redondear2

Continúa leyendo

En esta ocasión vamos a crear una sencilla aplicación para calcular, de manera automática, el día de la semana que corresponde a una fecha cualquiera. Para ello vamos a utilizar dos funciones: DÍASEM y BUSCARV.
Primero veamos qué eso que hace cada una de estas funciones y los parámetros que admiten:
  • DÍASEM(número; tipo): Devuelve un valor numérico del 1 al 7 que se corresponde con el día de la semana de una fecha cualquiera.
    Siendo “número” el valor de  una fecha cualquiera y si tipo=1 (o se omite), los días de la semana se cuentan a partir del domingo. Para tipo=2, los días de la semana se cuentan a partir del lunes=1. En tipo=3, los días de la semana se cuentan a partir del lunes=0.
    NOTA: Para conocer si un día en A1 es laboral, utilice las funciones SI y DÍASEM del siguiente modo: =SI(DÍASEM(A1;2)<6;”Día laboral”;”Fin de semana”)
  • BUSCARV(valor; matriz, índice, ordenar): Búsqueda vertical de un valor dentro de una matriz de datos.
    Siendo “valor” el valor que se busca den la primera columna de la matriz, “matriz” es el conjunto de celdas donde se realiza la búsqueda (debe comprender al menos dos columnas), “índice” indica en qué columna se encuentra el valor que se va a devolver y “ordenar” es un parámetro opcional que indica si la primera columna de la matriz se ordena en orden ascendente.

Para empezar, introducimos en la celda B3 una fecha cualquiera, por ejemplo “22/09/2016”, y en la celda B4 ponemos la función DÍASEM: =DÍASEM(B3; 2), con lo que indicamos que queremos calcular el valor numérico (del 1 al 7) que le corresponde al día de la semana de fecha introducida en la celda B3 y que el primer día de la semana es el lunes. La función devuelve el valor “4”, lo cual indica que el 22 de septiembre de 2016 fue jueves.

diasem_1
Continúa leyendo

Esta es una plantilla sencilla para confeccionar presupuestos.
Como se puede apreciar en la imagen, la plantilla consta de dos marcos para insertar los datos de la empresa y del cliente, otro marco para insertar los datos del presupuesto (número y fecha del mismo) y el cuerpo del presupuesto propiamente dicho.
En esta plantilla se puede insertar un descuento por cada artículo y no es necesario realizar ningún cálculo, ya que estos se realizan de manera automática.
presupuesto
Puedes descargar la plantilla de Calc en este ENLACE.