LibreOffice Base es capaz de manejar diversos formatos de archivo de bases de datos, como Access o dBase y también conectarse a bases relacionales externas como MySQL, PostgreSQL u Oracle. Y todo ello con la ayuda de un asistente que simplificará mucho el trabajo del usuario.

Para crear un archivo de base de datos, ejecutamos LibreOffice Base, o bien desde cualquiera de los componentes de LibreOffice desde Archivo->Nuevo->Base de datos. En cualquier caso se nos abrirá el Asistente de bases de datos que nos permitirá crear fácilmente una base de datos.

base01En la primera pantalla del Asistente para bases de datos, seleccionaremos lo que queremos hacer (Crear una base de datos nueva, Abrir una base de datos existente o Conectar con una base de datos existente) y pulsaremos sobre el botón Siguiente.

base02Seguidamente se nos preguntará si deseamos registrar la base de datos y, una vez guardado el archivo, qué queremos hacer con él, abrirlo para editarlo y/o crear tablas usando el asistente. Una vez marcadas las opciones que nos interesen pulsaremos sobre Finalizar.

base03Le damos ahora nombre al archivo, seleccionamos la capeta donde se guardará y pulsaremos sobre Guardar.

base04Una vez realizado el proceso anterior se nos abrirá una ventana con la nueva base de datos creada. Desde aquí podemos ver y crear todos los elementos de la base: Tablas, Consultas, Formularios e Informes.

Suele ocurrir que, en ocasiones, en la celda donde se esperaba obtener el valor resultante de determinado cálculo, se obtiene un extraño mensaje, casi incomprensible, con todas las letras en mayúsculas, que comienza con el signo "#" y que termina con un signo de exclamación "!" o, en otros casos, con un signo de interrogación "?" A este mensaje se le llama código de error. Su misión consiste en informar de que se ha producido en error en la fórmula o función utilizada, ya sea en la propia formula o en alguna celda a la que hace referencia dicha fórmula.
Después de que un código de error aparezca en una celda, se tiene que descubrir qué causó el error y editar la fórmula para poder continuar.
Estos son los códigos de error más habituales en Calc:
 

#¡DIV/0! Aparece cuando en la fórmula existe una división por cero o, como suele suceder habitualmente, la celda por la que hay que dividir no contiene ningún valor. Algunas otras funciones devolveran este error, por ejemplo:

  • VARP con menos que 1 argumento
  • STDEVP con menos de 1 argumento
  • VAR con menos de 2 argumentos
  • DESVEST con menos de 2 argumentos
  • STANDARDIZE con stdev=0
  • NORMDIST con stdev=0

#¿NOMBRE? Aparece cuando la fórmula se refiere a un nombre de rango que no existe en la hoja de trabajo. Este valor de error aparece cuando no se ha podido evaluar un identificador; por ejemplo, no hay referencia válida, nombre de dominio válido, etiqueta de columna/fila, macro, separador de decimales incorrecto, no se ha encontrado add-in.

#¡NUM! Aparece cuando Calc encuentra un problema con un número en la fórmula usada, tal como el tipo equivocado de argumento o un cálculo que produce un número demasiado grande o demasiado pequeño para ser representado en la hoja de trabajo.

#¡REF! Indica que Calc ha encontrado una referencia no válida a una celda, como cuando se elimina una celda a la que se hace referencia en la fórmula.

#¡VALOR! Señala que se ha utilizado un tipo incorrecto de argumento o cuando una celda que está referenciada dentro de una fórmula contiene texto en vez de un número.

Calc dispone de varias funciones para redondear números, con el uso de estas funciones se consigue que el resultado de una operación numérica aparezca con el formato deseado.

ENTERO(número): Redondea a la baja al entero más próximo.
Ejemplos:
=ENTERO(10,58) devuelve 10
=ENTERO(-3,36) devuelve -4

redondear1
REDONDEAR(número; número_de_decimales): Redondea un número hasta una cantidad determinada de decimales.
Ejemplos:
=REDONDEAR(6,35; 1) devuelve 6,4
=REDONDEAR(6,55; 1) devuelve 6,6
=REDONDEAR(6,35; 0) devuelve 6
=REDONDEAR(6,75; 0) devuelve 7

=REDONDEAR(2,348; 2) devuelve 2,35
=REDONDEAR(2,348; 0) devuelve 2
=REDONDEAR(2,5) devuelve 3
=REDONDEAR(987,65; -2) devuelve 1000

redondear2

...continúa leyendo "Funciones para redondear números en Calc"

En esta ocasión vamos a crear una sencilla aplicación para calcular, de manera automática, el día de la semana que corresponde a una fecha cualquiera. Para ello vamos a utilizar dos funciones: DÍASEM y BUSCARV.
Primero veamos qué eso que hace cada una de estas funciones y los parámetros que admiten:
  • DÍASEM(número; tipo): Devuelve un valor numérico del 1 al 7 que se corresponde con el día de la semana de una fecha cualquiera.
    Siendo "número" el valor de  una fecha cualquiera y si tipo=1 (o se omite), los días de la semana se cuentan a partir del domingo. Para tipo=2, los días de la semana se cuentan a partir del lunes=1. En tipo=3, los días de la semana se cuentan a partir del lunes=0.
    NOTA: Para conocer si un día en A1 es laboral, utilice las funciones SI y DÍASEM del siguiente modo: =SI(DÍASEM(A1;2)<6;"Día laboral";"Fin de semana")
  • BUSCARV(valor; matriz, índice, ordenar): Búsqueda vertical de un valor dentro de una matriz de datos.
    Siendo "valor" el valor que se busca den la primera columna de la matriz, "matriz" es el conjunto de celdas donde se realiza la búsqueda (debe comprender al menos dos columnas), "índice" indica en qué columna se encuentra el valor que se va a devolver y "ordenar" es un parámetro opcional que indica si la primera columna de la matriz se ordena en orden ascendente.

Para empezar, introducimos en la celda B3 una fecha cualquiera, por ejemplo "22/09/2016", y en la celda B4 ponemos la función DÍASEM: =DÍASEM(B3; 2), con lo que indicamos que queremos calcular el valor numérico (del 1 al 7) que le corresponde al día de la semana de fecha introducida en la celda B3 y que el primer día de la semana es el lunes. La función devuelve el valor "4", lo cual indica que el 22 de septiembre de 2016 fue jueves.

diasem_1
...continúa leyendo "Calc: cómo calcular el día de la semana"

Esta es una plantilla sencilla para confeccionar presupuestos.
Como se puede apreciar en la imagen, la plantilla consta de dos marcos para insertar los datos de la empresa y del cliente, otro marco para insertar los datos del presupuesto (número y fecha del mismo) y el cuerpo del presupuesto propiamente dicho.
En esta plantilla se puede insertar un descuento por cada artículo y no es necesario realizar ningún cálculo, ya que estos se realizan de manera automática.
presupuesto
Puedes descargar la plantilla de Calc en este ENLACE.

En Calc un hiperenlace es un enlace desde el que se puede acceder a una determinada sección de la hoja actual, a otra hoja, a un documento externo, a una dirección de correo electrónico o a una página web determinada.
Como norma general, los enlaces o hipervínculos, aparecen en texto azul y con subrayado, de esta forma son fáciles de identificar y localizar.
Para insertar un hiperenlaceo basta con seleccionar la celda que lo va a contener y, desde el menú "Insertar", seleccionar "Hiperenlace..." y aparece la siguiente ventana:Hiperenlace Calc

Tipos de hiperenlaces en Calc

El diálogo Hiperenlace tiene 4 pestañas:

  1.  Internet. Crea un enlace a un archivo que se encuentra en el equipo o a la dicción de una página web. Una vez que se ha seleccionado la celda que va a contener el hiperenlace, se accede a la ventana de diálogo "Hiperenlace..." como se muestra en la figura anterior.
    En el cuadro "Texto:" se introduce el título del enlace, es decir, el texto que va a parecer en la celda seleccionada.
    Hiperenlace CalcEn el cuadro "URL:" se especifica la dirección de la página Web o FTP a la que se desea acceder.
    Opcionalmente en "Formulario:" podemos escoger que el enlace no se vea como un simple texto, sino que tenga forma de botón. ...continúa leyendo "Calc: creando hiperenlaces"

Celdas protegidas en Calc

Con frecuencia es necesario diseñar hojas de cálculo que van a ser usadas por otras personas, a veces estas hojas contienen fórmulas o determinados formatos que no se deben cambiar para el correcto funcionamiento de la aplicación.

En el siguiente tutorial aprenderás cómo evitar que las celdas puedan modificarse en una hoja de cálculo de LibreOffice (también para OpenOffice) y así proteger algunas celdas o toda la hoja de cálculo.

Proteger todas las celdas de la hoja:

Para bloquear todas las celdas de la hoja o del documento completo con contraseña seguiremos los siguientes pasos:

  1. Entra en una hoja de cálculo de LibreOffice.
  2. Abre el menú Herramientas y despliega la opción Proteger hoja...
  3. Escribe una Contraseña, también la misma contraseña en Confirmar y pulsa el botón “Aceptar”. Recuerda la contraseña ya que la necesitarás si quieres modificar o dejar el documento desprotegido en el futuro.
    Proteger hoja en LibreOffice Calc
  4. Ya tenemos protegidas todas las celdas de las hojas. Puedes comprobar que al intentar modificar una celda aparece un mensaje del tipo: “No se pueden modificar las celdas protegidas.”
  • En caso que quieras dejar el documento cómo estaba en un principio y poder modificar las celdas, ve a Herramientas > Proteger hoja... escribes la contraseña que habías utilizado con anterioridad y pulsas en Aceptar.

...continúa leyendo "Calc: Proteger celdas en la hoja de cálculo"

Calc dispone de una gran cantidad de funciones estadísticas capaces de realizar complejos cálculos matemáticos.

funciones-estadisticaEstas son algunas de las más usadas:
  • CONTAR(valor1; valor2; ... valor30): Cuenta el número de celdas que contienen valores numéricos dentro en un grupo de celdas. No se toman en consideración las entradas de texto.
    Ejemplo: =CONTAR(A1:A10) Devuelve el número de celdas que contienen valores numéricos dentro del rango A1:A10.
  • CONTAR.BLANCO(valor1; valor2; ... valor30): Cuenta el número de celdas vacías, esto es, que contienen un valor en blanco dentro de un rango específico.
    Ejemplo: =CONTAR.BLANCOA1:A10) Devuelve el número de celdas vacías dentro del rango A1:A10.
  • CONTAR.SI(rango; condición): Cuenta el número de celdas en un rango que cumplen una determinada condición. Ejemplos:
    =CONTAR.SI(A1:A10; "<10") Devuelve el número de celdas que contienen valores numéricos menores de 10 dentro del rango A1:A10.
    =CONTAR.SI(A1:A10; "hombre") Devuelve el número de celdas que contienen la palabra "hombre" dentro del rango A1:A10.
    Para contar únicamente los números negativos: =CONTAR.SI(A1:A10;"<0")

...continúa leyendo "Las funciones estadísticas en Calc"

La potencia de Calc permite realizar, en pocos minutos, útiles aplicaciones de manera sencilla y con total fiabilidad. En este caso se trata de una sencilla plantilla para el control de los gastos familiares.
control-de-gastos

Puedes descargar la plantilla de Calc en este ENLACE.

La potencia de Calc permite crear con facilidad todo tipo de formularios y plantillas, en este artículo vamos a ver como diseñar un modelo sencillo de factura.
Una factura es un documento legal que todo profesional, empresario o autónomo está obligado a emitir a la hora de realizar cualquier operación económica. Este documento debe reflejar toda la información necesaria sobre dicha operación.
El modelo que hemos plasmado aquí es de carácter general y puede ser modificado según lo requieran las circunstancias.
factura-simpleComo se puede apreciar hemos reservado un espacio para el anagrama de la empresa, otro para los datos del cliente a quien se factura, otro para los datos de la empresa y uno más para indicar, de forma bien visible, la fecha y el número de factura. A continuación están ubicados los detalles, precios y subtotales. Finalmente, en la parte inferior, hemos habilitado unas celdas para el IVA, el importe total de la factura y la forma de pago.
Los únicos cálculos que hemos realizado son el producto de CANTIDAD x PRECIO en la columna TOTAL, la suma de la columna TOTAL en SUMA, el porcentaje de IVA en IVA y el importe total de la factura en TOTAL FACTURA.
Puedes descargar la plantilla de Calc en este ENLACE.