Funciones lógicas en Calc

Las funciones lógicas son aquellas que sólo devuelven los valores VERDADERO o FALSO.
funciones-logico
Entre ellas están las siguientes:
=FALSO(): Siempre devuelve el valor lógico FALSO. Esta función no tiene argumentos.
Ejemplos:
=FALSO() Devuelve FALSO
=NO(FALSO()) Devuelve VERDADERO
FALSO()
=NO(valor_lógico): Devuelve el valor lógico del argumento invertido, es decir, si la función recibe un valor FALSO devuelve VERDADERO y si recibe VERDADERO devuelve FALSO. El argumento valor_lógico debe ser una expresión que pueda evaluarse como VERDADERO o FALSO.
Ejemplo:
=NO("Falso") Devuelve VERDADERO
=NO(1) Devuelve FALSO
=NO(0) Devuelve VERDADERO
NO()
=O(valor_lógico_1; valor_lógico_2; ...; valor_lógico_30): Devuelve VERDADERO si al menos uno de los argumentos es VERDADERO. Los argumentos o condiciones que acepta la función son de 1 a 30.
Ejemplos:
=O(1+1=3; 2+2=5) Devuelve FALSO pues todas las condiciones son falsas.
=O(FALSO; VERDADERO; FALSO) Devuelve VERDADERO pues una de las condiciones es verdadera.
O()
Para más información acerca de esta función ver la entrada: Las funciones lógicas Y y O en Calc.

=SI(prueba_lógica; valor_si_verdadero; valor_si_falso): Devuelve un valor si una condición indicada es VERDADERO y otro valor si es FALSO. El argumento prueba_lógica es la condición que se desea evaluar, valor_si_verdadero es el resultado que devuelve la función en caso de que la condición evaluada sea VERDADERO y valor_si_falso es el valor devuelto en caso contrario.
Ejemplo:
=SI(A1>5;"Mayor de 5";"Menor o igual a 5") devuelve "Mayor de 5" si el valor que contiene la celda A1 es mayor que 5 o "Menor o igual a 5" si A1 es menor o igual que
Para más información acerca de esta función ver artículo: Calc: Función "SI( )"
=SI.ERROR(fórmula; valor_si_hay_error): Comprueba si se produce un error en la fórmula indicada. En caso de que no haya error devuelve al valor calculado por la fórmula, de lo contrario, devuelve el valor indicado en el argumento valor_si_hay_error. Esta función se utiliza para interceptar errores en las fórmulas.
Ejemplo:
=SI.ERROR(A1/B1; "Error en la fórmula") Devuelve el resultado de dividir el valor de la celda A1 entre el valor contenido en la celda B1, en caso de que esta fórmula de un error devuelve "Error en la fórmula". SI.ERROR()=VERDADERO(): Siempre devuelve el valor lógico VERDADERO. Esta función no tiene argumentos.
Ejemplo:
=VERDADERO() Devuelve el valor "VERDADERO"
VERDADERO()
=XOR(valor_lógico_1; valor_lógico_2; ...; valor_lógico_30): Devuelve VERDADERO si un número impar de argumentos evalúa a VERDADERO.
Los argumentos pueden ser expresiones lógicas (VERDADERO, 1<5, 2+3=7, B8<10) que devuelven valores lógicos, o intervalos de celdas (A1:C3) que contienen valores lógicos.
Los argumentos o condiciones que acepta la función son de 1 a 30.
Ejemplos:
=XOR(1+1=2; 2+2=4) Devuelve FALSO pues 2 (par) condiciones son verdaderas.
=XOR(1; 0; 0) Devuelve VERDADERO.
XOR()

=Y(valor_lógico_1; valor_lógico_2; ...; valor_lógico_30): Devuelve VERDADERO si todos los argumentos son VERDADERO y FALSO cuando al menos uno de los argumentos es FALSO.
Los argumentos o condiciones que acepta la función son de 1 a 30.
Ejemplos:
=Y(1+1=2; 2+2=4) Devuelve VERDADERO pues todas las condiciones son verdaderas.
=Y(VERDADERO; VERDADERO; FALSO) Devuelve FALSO pues una de las condiciones es falsa.

Y()
Para más información acerca de esta función ver la entrada: Las funciones lógicas Y y O en Calc.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*