Saltar al contenido

solver-8Solver (o Solucionador) es una de las herramientas más potentes de que disponemos en Calc.

El algoritmo Solver permite la optimización y asignación eficiente de recursos escasos (tierra, trabajo, capital, capacidad gerencial, etc.), de tal manera que se cumplan las metas deseadas, como son la maximización de los beneficios, o la minimización de los costos.
Solver utiliza el método de la Programación Lineal (LP), es una técnica muy potente de asignación de recursos para resolver problemas para negocios y organizaciones.
En este artículo vamos a ver que no es nada difícil su uso y que nos puede resultar extremadamente útil para resolver funciones complejas.
Lo primero que tenemos que aclarar es: ¿Para qué sirve Solver? ¿Qué hace Solver? Pues bien, Solver es una herramienta usada para hacer cálculos matemáticos complejos, las posibilidades son múltiples y muy variadas, para ver cómo funciona vamos a realizar un ejemplo desarrollando una aplicación que nos resuelva un problema concreto.
Supongamos que un vendedor de productos informáticos desea realizar un pedido para ampliar el stock de determinados productos, los productos que necesita y los precios de cada uno son los siguientes:
  • Placas Base: 90€
  • Microprocesadores: 65€
  • Ventiladores: 12€
Para realizar el pedido dispone de un máximo de 3.000€, ahora bien, hay una limitación en la cantidad mínima que el distribuidor suministra de cada componente, estas cantidades mínimas son las siguientes:
  • Placas Base: pedido mínimo 10 unidades
  • Microprocesadores: pedido mínimo 5 unidades
  • Ventiladores: pedido mínimo 10 unidades

...continúa leyendo "Calc: resolver ecuaciones con SOLVER"

La función matemática SUMA resulta especialmente útil. Su misión, como su nombre indica, es la de sumar todos los valores de un área de celdas, ya sean celdas específicas o las de un rango de celdas. Como para todas las formulas en Calc debemos escribir el signo "=" antes que la función, de esta manera le indicamos al programa que lo que viene a continuación es una fórmula.
suma1
Función matemática SUMA
Para sumar celdas concretas, la sintaxis es:  =SUMA(A1; B3; A2). Este ejemplo lo que hace es sumar las cantidades contenidas en las celdas A1, B3 y A2. Los sumandos deben aparecer separados por ";" y entre paréntesis.
También podemos incluir en la función SUMA cantidades fijas, como por ejemplo: =SUMA(A6; C7; 4). Ahora la función nos devuelve la suma de las cantidades contenidas en A6 y C7 y le suma una cantidad fija, el 4.
Si lo que deseamos es sumar un rango de celdas debemos indicar en la función el comienzo y el final del mismo, separados por el signo ":". Veamos unos ejemplos:
  Para sumar los datos de una columna: =SUMA(B1:B10), nos suma los datos contenidos en la columna B, empezando en B1 y terminando en B10.
  Para sumar los datos de una fila la fórmula es igual, indicamos el inicio y el final separados por ":", o sea, =SUMA(A5:C5).
También podemos combinar la suma de celdas sueltas y celdas contenidas en un rango, por ejemplo: =SUMA(B2:B8; C9), esta fórmula nos devuelve la suma de las celdas contenidas entre B2 y B8 y, a continuación, la suma el valor de C9.

En la siguiente imagen se puede apreciar el resultado de los ejemplos anteriores:

suma2

Como se puede apreciar las combinaciones y posibilidades de la función SUMA son múltiples, sólo es cuestión de imaginación y conseguiremos adaptar la fórmula a nuestras necesidades.

En Calc existen varias métodos para Copiar y Pegar texto. En este artículo veremos cuáles son y las formas más apropiadas de usarlas para simplificar el proceso y hacerlo más rápido y eficaz.
La primera sería  utilizar el menú "Editar". Seleccionamos la ceda o grupo de celdas que deseamos copiar, pinchamos en "Editar" y acto seguido en "Copiar". Luego nos situamos en la celda de destino, donde queremos copiar los datos, y repetimos el proceso: volvemos a pulsar en "Editar" y a continuación en "Pegar". Este sin duda es el método más sencillo, pero también el más lento y tedioso.
copiar-y-pegar_1
Copiar y Pegar usando el Menú "Editar"

...continúa leyendo "Calc: Copiar y Pegar de manera eficiente"

La función lógica SI resulta muy útil, se usa para comprobar si se cumple una determinada condición y devuelve un valor en función del resultado de la consulta.
función SI
Función lógica SI

SI devuelve un valor si la condición especificada se evalúa como VERDADERO y otro valor si se evalúa como FALSO.

La sintaxis es:
SI( Prueba_lógica; Valor_si_verdadero; Valor_si_falso )
  • Prueba_lógica es la condición que queremos comprobar.
  • Valor_si_verdadero es el valor que devuelve en caso de que la prueba lógica sea cierta.
  • Valor_si_falso es el valor que devuelve en caso de que la prueba lógica sea falsa.
Ejemplo, la fórmula =SI(B13 >= 5; "Aprobado"; "Suspenso") devuelve "Aprobado" si B3 es mayor o igual que 5 y "Suspenso" si B3 es menor que 5.
Los parámetros deben aparecer como se indica en el ejemplo, es decir, deben estar entre paréntesis y separados por punto y coma ( ; ).
Ejemplo función SI
Ejemplo función SI()

Escrito por Ricardo Gabriel Berlasso (RGB)Domando al escritor se centra en las herramientas que proporciona OOo Writer para la construcción automática de documentos estructurados (estilos de párrafo jerárquicos, estilos de carácter, estilos de página, campos, variables, índice, bibliografías…), herramientas que pueden parecer excesivamente «pesadas» a quien solo tiene que escribir un par de páginas de vez en cuando pero que son la salvación de quienes deben escribir una tesis, una revisión, o un libro.

EDITO (abril 2016): La edición 2016 del libro
dedicada a LibreOffice Writer 5.1. ya está disponible.

Desde el correcto uso de estilos y plantillas hasta la estructura de los archivos odt, pasando por el uso de OOo Math y OOo Draw, los campos y las referencias cruzadas, la base de datos bibliográfica, el correcto uso del registro de página, ligaduras tipográficas gracias a la tecnología Graphite… y un largo etcétera que se extiende por más de 300 páginas, el lector encontrará en este volumen todo lo necesario para trabajar con OOo/LibO Writer en su máximo potencial.

La tercera edición del libro, además de actualizar, reorganizar y extender el contenido (y corregir algunos errores…), agrega un nuevo capítulo dedicado al trabajo colaborativo.

Las diferencias entre OpenOffice.org Writer y LibreOffice Writer son también comentadas en detalle.

Descarga la versión en pdf de "Domando al escritor",
versión 3: desde aquí,
versión 2013 (OOo 4.x): desde aquí, y
versión 2016 (Lib 5.1): desde aquí.

Es posible adquirir una copia impresa en este enlace.

Visto (inicialmente) en: Gnometips.com.