LibreOffice Base es capaz de manejar diversos formatos de archivo de bases de datos, como Access o dBase y también conectarse a bases relacionales externas como MySQL, PostgreSQL u Oracle. Y todo ello con la ayuda de un asistente que simplificará mucho el trabajo del usuario.

Para crear un archivo de base de datos, ejecutamos LibreOffice Base, o bien desde cualquiera de los componentes de LibreOffice desde Archivo->Nuevo->Base de datos. En cualquier caso se nos abrirá el Asistente de bases de datos que nos permitirá crear fácilmente una base de datos.

base01En la primera pantalla del Asistente para bases de datos, seleccionaremos lo que queremos hacer (Crear una base de datos nueva, Abrir una base de datos existente o Conectar con una base de datos existente) y pulsaremos sobre el botón Siguiente.

base02Seguidamente se nos preguntará si deseamos registrar la base de datos y, una vez guardado el archivo, qué queremos hacer con él, abrirlo para editarlo y/o crear tablas usando el asistente. Una vez marcadas las opciones que nos interesen pulsaremos sobre Finalizar.

base03Le damos ahora nombre al archivo, seleccionamos la capeta donde se guardará y pulsaremos sobre Guardar.

base04Una vez realizado el proceso anterior se nos abrirá una ventana con la nueva base de datos creada. Desde aquí podemos ver y crear todos los elementos de la base: Tablas, Consultas, Formularios e Informes.

Suele ocurrir que, en ocasiones, en la celda donde se esperaba obtener el valor resultante de determinado cálculo, se obtiene un extraño mensaje, casi incomprensible, con todas las letras en mayúsculas, que comienza con el signo "#" y que termina con un signo de exclamación "!" o, en otros casos, con un signo de interrogación "?" A este mensaje se le llama código de error. Su misión consiste en informar de que se ha producido en error en la fórmula o función utilizada, ya sea en la propia formula o en alguna celda a la que hace referencia dicha fórmula.
Después de que un código de error aparezca en una celda, se tiene que descubrir qué causó el error y editar la fórmula para poder continuar.
Estos son los códigos de error más habituales en Calc:
 

#¡DIV/0! Aparece cuando en la fórmula existe una división por cero o, como suele suceder habitualmente, la celda por la que hay que dividir no contiene ningún valor. Algunas otras funciones devolveran este error, por ejemplo:

  • VARP con menos que 1 argumento
  • STDEVP con menos de 1 argumento
  • VAR con menos de 2 argumentos
  • DESVEST con menos de 2 argumentos
  • STANDARDIZE con stdev=0
  • NORMDIST con stdev=0

#¿NOMBRE? Aparece cuando la fórmula se refiere a un nombre de rango que no existe en la hoja de trabajo. Este valor de error aparece cuando no se ha podido evaluar un identificador; por ejemplo, no hay referencia válida, nombre de dominio válido, etiqueta de columna/fila, macro, separador de decimales incorrecto, no se ha encontrado add-in.

#¡NUM! Aparece cuando Calc encuentra un problema con un número en la fórmula usada, tal como el tipo equivocado de argumento o un cálculo que produce un número demasiado grande o demasiado pequeño para ser representado en la hoja de trabajo.

#¡REF! Indica que Calc ha encontrado una referencia no válida a una celda, como cuando se elimina una celda a la que se hace referencia en la fórmula.

#¡VALOR! Señala que se ha utilizado un tipo incorrecto de argumento o cuando una celda que está referenciada dentro de una fórmula contiene texto en vez de un número.

Calc dispone de varias funciones para redondear números, con el uso de estas funciones se consigue que el resultado de una operación numérica aparezca con el formato deseado.

ENTERO(número): Redondea a la baja al entero más próximo.
Ejemplos:
=ENTERO(10,58) devuelve 10
=ENTERO(-3,36) devuelve -4

redondear1
REDONDEAR(número; número_de_decimales): Redondea un número hasta una cantidad determinada de decimales.
Ejemplos:
=REDONDEAR(6,35; 1) devuelve 6,4
=REDONDEAR(6,55; 1) devuelve 6,6
=REDONDEAR(6,35; 0) devuelve 6
=REDONDEAR(6,75; 0) devuelve 7

=REDONDEAR(2,348; 2) devuelve 2,35
=REDONDEAR(2,348; 0) devuelve 2
=REDONDEAR(2,5) devuelve 3
=REDONDEAR(987,65; -2) devuelve 1000

redondear2

...continúa leyendo "Funciones para redondear números en Calc"

En esta ocasión vamos a crear una sencilla aplicación para calcular, de manera automática, el día de la semana que corresponde a una fecha cualquiera. Para ello vamos a utilizar dos funciones: DÍASEM y BUSCARV.
Primero veamos qué eso que hace cada una de estas funciones y los parámetros que admiten:
  • DÍASEM(número; tipo): Devuelve un valor numérico del 1 al 7 que se corresponde con el día de la semana de una fecha cualquiera.
    Siendo "número" el valor de  una fecha cualquiera y si tipo=1 (o se omite), los días de la semana se cuentan a partir del domingo. Para tipo=2, los días de la semana se cuentan a partir del lunes=1. En tipo=3, los días de la semana se cuentan a partir del lunes=0.
    NOTA: Para conocer si un día en A1 es laboral, utilice las funciones SI y DÍASEM del siguiente modo: =SI(DÍASEM(A1;2)<6;"Día laboral";"Fin de semana")
  • BUSCARV(valor; matriz, índice, ordenar): Búsqueda vertical de un valor dentro de una matriz de datos.
    Siendo "valor" el valor que se busca den la primera columna de la matriz, "matriz" es el conjunto de celdas donde se realiza la búsqueda (debe comprender al menos dos columnas), "índice" indica en qué columna se encuentra el valor que se va a devolver y "ordenar" es un parámetro opcional que indica si la primera columna de la matriz se ordena en orden ascendente.

Para empezar, introducimos en la celda B3 una fecha cualquiera, por ejemplo "22/09/2016", y en la celda B4 ponemos la función DÍASEM: =DÍASEM(B3; 2), con lo que indicamos que queremos calcular el valor numérico (del 1 al 7) que le corresponde al día de la semana de fecha introducida en la celda B3 y que el primer día de la semana es el lunes. La función devuelve el valor "4", lo cual indica que el 22 de septiembre de 2016 fue jueves.

diasem_1
...continúa leyendo "Calc: cómo calcular el día de la semana"

En Calc un hiperenlace es un enlace desde el que se puede acceder a una determinada sección de la hoja actual, a otra hoja, a un documento externo, a una dirección de correo electrónico o a una página web determinada.
Como norma general, los enlaces o hipervínculos, aparecen en texto azul y con subrayado, de esta forma son fáciles de identificar y localizar.
Para insertar un hiperenlaceo basta con seleccionar la celda que lo va a contener y, desde el menú "Insertar", seleccionar "Hiperenlace..." y aparece la siguiente ventana:Hiperenlace Calc

Tipos de hiperenlaces en Calc

El diálogo Hiperenlace tiene 4 pestañas:

  1.  Internet. Crea un enlace a un archivo que se encuentra en el equipo o a la dicción de una página web. Una vez que se ha seleccionado la celda que va a contener el hiperenlace, se accede a la ventana de diálogo "Hiperenlace..." como se muestra en la figura anterior.
    En el cuadro "Texto:" se introduce el título del enlace, es decir, el texto que va a parecer en la celda seleccionada.
    Hiperenlace CalcEn el cuadro "URL:" se especifica la dirección de la página Web o FTP a la que se desea acceder.
    Opcionalmente en "Formulario:" podemos escoger que el enlace no se vea como un simple texto, sino que tenga forma de botón. ...continúa leyendo "Calc: creando hiperenlaces"

Celdas protegidas en Calc

Con frecuencia es necesario diseñar hojas de cálculo que van a ser usadas por otras personas, a veces estas hojas contienen fórmulas o determinados formatos que no se deben cambiar para el correcto funcionamiento de la aplicación.

En el siguiente tutorial aprenderás cómo evitar que las celdas puedan modificarse en una hoja de cálculo de LibreOffice (también para OpenOffice) y así proteger algunas celdas o toda la hoja de cálculo.

Proteger todas las celdas de la hoja:

Para bloquear todas las celdas de la hoja o del documento completo con contraseña seguiremos los siguientes pasos:

  1. Entra en una hoja de cálculo de LibreOffice.
  2. Abre el menú Herramientas y despliega la opción Proteger hoja...
  3. Escribe una Contraseña, también la misma contraseña en Confirmar y pulsa el botón “Aceptar”. Recuerda la contraseña ya que la necesitarás si quieres modificar o dejar el documento desprotegido en el futuro.
    Proteger hoja en LibreOffice Calc
  4. Ya tenemos protegidas todas las celdas de las hojas. Puedes comprobar que al intentar modificar una celda aparece un mensaje del tipo: “No se pueden modificar las celdas protegidas.”
  • En caso que quieras dejar el documento cómo estaba en un principio y poder modificar las celdas, ve a Herramientas > Proteger hoja... escribes la contraseña que habías utilizado con anterioridad y pulsas en Aceptar.

...continúa leyendo "Calc: Proteger celdas en la hoja de cálculo"

Calc dispone de una gran cantidad de funciones estadísticas capaces de realizar complejos cálculos matemáticos.

funciones-estadisticaEstas son algunas de las más usadas:
  • CONTAR(valor1; valor2; ... valor30): Cuenta el número de celdas que contienen valores numéricos dentro en un grupo de celdas. No se toman en consideración las entradas de texto.
    Ejemplo: =CONTAR(A1:A10) Devuelve el número de celdas que contienen valores numéricos dentro del rango A1:A10.
  • CONTAR.BLANCO(valor1; valor2; ... valor30): Cuenta el número de celdas vacías, esto es, que contienen un valor en blanco dentro de un rango específico.
    Ejemplo: =CONTAR.BLANCOA1:A10) Devuelve el número de celdas vacías dentro del rango A1:A10.
  • CONTAR.SI(rango; condición): Cuenta el número de celdas en un rango que cumplen una determinada condición. Ejemplos:
    =CONTAR.SI(A1:A10; "<10") Devuelve el número de celdas que contienen valores numéricos menores de 10 dentro del rango A1:A10.
    =CONTAR.SI(A1:A10; "hombre") Devuelve el número de celdas que contienen la palabra "hombre" dentro del rango A1:A10.
    Para contar únicamente los números negativos: =CONTAR.SI(A1:A10;"<0")

...continúa leyendo "Las funciones estadísticas en Calc"

solver-8Solver (o Solucionador) es una de las herramientas más potentes de que disponemos en Calc.

El algoritmo Solver permite la optimización y asignación eficiente de recursos escasos (tierra, trabajo, capital, capacidad gerencial, etc.), de tal manera que se cumplan las metas deseadas, como son la maximización de los beneficios, o la minimización de los costos.
Solver utiliza el método de la Programación Lineal (LP), es una técnica muy potente de asignación de recursos para resolver problemas para negocios y organizaciones.
En este artículo vamos a ver que no es nada difícil su uso y que nos puede resultar extremadamente útil para resolver funciones complejas.
Lo primero que tenemos que aclarar es: ¿Para qué sirve Solver? ¿Qué hace Solver? Pues bien, Solver es una herramienta usada para hacer cálculos matemáticos complejos, las posibilidades son múltiples y muy variadas, para ver cómo funciona vamos a realizar un ejemplo desarrollando una aplicación que nos resuelva un problema concreto.
Supongamos que un vendedor de productos informáticos desea realizar un pedido para ampliar el stock de determinados productos, los productos que necesita y los precios de cada uno son los siguientes:
  • Placas Base: 90€
  • Microprocesadores: 65€
  • Ventiladores: 12€
Para realizar el pedido dispone de un máximo de 3.000€, ahora bien, hay una limitación en la cantidad mínima que el distribuidor suministra de cada componente, estas cantidades mínimas son las siguientes:
  • Placas Base: pedido mínimo 10 unidades
  • Microprocesadores: pedido mínimo 5 unidades
  • Ventiladores: pedido mínimo 10 unidades

...continúa leyendo "Calc: resolver ecuaciones con SOLVER"

La función matemática SUMA resulta especialmente útil. Su misión, como su nombre indica, es la de sumar todos los valores de un área de celdas, ya sean celdas específicas o las de un rango de celdas. Como para todas las formulas en Calc debemos escribir el signo "=" antes que la función, de esta manera le indicamos al programa que lo que viene a continuación es una fórmula.
suma1
Función matemática SUMA
Para sumar celdas concretas, la sintaxis es:  =SUMA(A1; B3; A2). Este ejemplo lo que hace es sumar las cantidades contenidas en las celdas A1, B3 y A2. Los sumandos deben aparecer separados por ";" y entre paréntesis.
También podemos incluir en la función SUMA cantidades fijas, como por ejemplo: =SUMA(A6; C7; 4). Ahora la función nos devuelve la suma de las cantidades contenidas en A6 y C7 y le suma una cantidad fija, el 4.
Si lo que deseamos es sumar un rango de celdas debemos indicar en la función el comienzo y el final del mismo, separados por el signo ":". Veamos unos ejemplos:
  Para sumar los datos de una columna: =SUMA(B1:B10), nos suma los datos contenidos en la columna B, empezando en B1 y terminando en B10.
  Para sumar los datos de una fila la fórmula es igual, indicamos el inicio y el final separados por ":", o sea, =SUMA(A5:C5).
También podemos combinar la suma de celdas sueltas y celdas contenidas en un rango, por ejemplo: =SUMA(B2:B8; C9), esta fórmula nos devuelve la suma de las celdas contenidas entre B2 y B8 y, a continuación, la suma el valor de C9.

En la siguiente imagen se puede apreciar el resultado de los ejemplos anteriores:

suma2

Como se puede apreciar las combinaciones y posibilidades de la función SUMA son múltiples, sólo es cuestión de imaginación y conseguiremos adaptar la fórmula a nuestras necesidades.

En Calc existen varias métodos para Copiar y Pegar texto. En este artículo veremos cuáles son y las formas más apropiadas de usarlas para simplificar el proceso y hacerlo más rápido y eficaz.
La primera sería  utilizar el menú "Editar". Seleccionamos la ceda o grupo de celdas que deseamos copiar, pinchamos en "Editar" y acto seguido en "Copiar". Luego nos situamos en la celda de destino, donde queremos copiar los datos, y repetimos el proceso: volvemos a pulsar en "Editar" y a continuación en "Pegar". Este sin duda es el método más sencillo, pero también el más lento y tedioso.
copiar-y-pegar_1
Copiar y Pegar usando el Menú "Editar"

...continúa leyendo "Calc: Copiar y Pegar de manera eficiente"