En esta ocasión vamos a crear una sencilla aplicación para calcular, de manera automática, el día de la semana que corresponde a una fecha cualquiera. Para ello vamos a utilizar dos funciones: DÍASEM y BUSCARV.
Primero veamos qué eso que hace cada una de estas funciones y los parámetros que admiten:
  • DÍASEM(número; tipo): Devuelve un valor numérico del 1 al 7 que se corresponde con el día de la semana de una fecha cualquiera.
    Siendo “número” el valor de  una fecha cualquiera y si tipo=1 (o se omite), los días de la semana se cuentan a partir del domingo. Para tipo=2, los días de la semana se cuentan a partir del lunes=1. En tipo=3, los días de la semana se cuentan a partir del lunes=0.
    NOTA: Para conocer si un día en A1 es laboral, utilice las funciones SI y DÍASEM del siguiente modo: =SI(DÍASEM(A1;2)<6;”Día laboral”;”Fin de semana”)
  • BUSCARV(valor; matriz, índice, ordenar): Búsqueda vertical de un valor dentro de una matriz de datos.
    Siendo “valor” el valor que se busca den la primera columna de la matriz, “matriz” es el conjunto de celdas donde se realiza la búsqueda (debe comprender al menos dos columnas), “índice” indica en qué columna se encuentra el valor que se va a devolver y “ordenar” es un parámetro opcional que indica si la primera columna de la matriz se ordena en orden ascendente.

Para empezar, introducimos en la celda B3 una fecha cualquiera, por ejemplo “22/09/2016”, y en la celda B4 ponemos la función DÍASEM: =DÍASEM(B3; 2), con lo que indicamos que queremos calcular el valor numérico (del 1 al 7) que le corresponde al día de la semana de fecha introducida en la celda B3 y que el primer día de la semana es el lunes. La función devuelve el valor “4”, lo cual indica que el 22 de septiembre de 2016 fue jueves.

diasem_1
Continúa leyendo

Esta es una plantilla sencilla para confeccionar presupuestos.
Como se puede apreciar en la imagen, la plantilla consta de dos marcos para insertar los datos de la empresa y del cliente, otro marco para insertar los datos del presupuesto (número y fecha del mismo) y el cuerpo del presupuesto propiamente dicho.
En esta plantilla se puede insertar un descuento por cada artículo y no es necesario realizar ningún cálculo, ya que estos se realizan de manera automática.
presupuesto
Puedes descargar la plantilla de Calc en este ENLACE.

En Calc un hiperenlace es un enlace desde el que se puede acceder a una determinada sección de la hoja actual, a otra hoja, a un documento externo, a una dirección de correo electrónico o a una página web determinada.
Como norma general, los enlaces o hipervínculos, aparecen en texto azul y con subrayado, de esta forma son fáciles de identificar y localizar.
Para insertar un hiperenlaceo basta con seleccionar la celda que lo va a contener y, desde el menú “Insertar”, seleccionar “Hiperenlace…” y aparece la siguiente ventana:Hiperenlace Calc

Tipos de hiperenlaces en Calc

El diálogo Hiperenlace tiene 4 pestañas:

  1.  Internet. Crea un enlace a un archivo que se encuentra en el equipo o a la dicción de una página web. Una vez que se ha seleccionado la celda que va a contener el hiperenlace, se accede a la ventana de diálogo “Hiperenlace…” como se muestra en la figura anterior.
    En el cuadro “Texto:” se introduce el título del enlace, es decir, el texto que va a parecer en la celda seleccionada.
    Hiperenlace CalcEn el cuadro “URL:” se especifica la dirección de la página Web o FTP a la que se desea acceder.
    Opcionalmente en “Formulario:” podemos escoger que el enlace no se vea como un simple texto, sino que tenga forma de botón.Continúa leyendo

Celdas protegidas en Calc

Con frecuencia es necesario diseñar hojas de cálculo que van a ser usadas por otras personas, a veces estas hojas contienen fórmulas o determinados formatos que no se deben cambiar para el correcto funcionamiento de la aplicación.

En el siguiente tutorial aprenderás cómo evitar que las celdas puedan modificarse en una hoja de cálculo de LibreOffice (también para OpenOffice) y así proteger algunas celdas o toda la hoja de cálculo.

Proteger todas las celdas de la hoja:

Para bloquear todas las celdas de la hoja o del documento completo con contraseña seguiremos los siguientes pasos:

  1. Entra en una hoja de cálculo de LibreOffice.
  2. Abre el menú Herramientas y despliega la opción Proteger hoja…
  3. Escribe una Contraseña, también la misma contraseña en Confirmar y pulsa el botón “Aceptar”. Recuerda la contraseña ya que la necesitarás si quieres modificar o dejar el documento desprotegido en el futuro.
    Proteger hoja en LibreOffice Calc
  4. Ya tenemos protegidas todas las celdas de las hojas. Puedes comprobar que al intentar modificar una celda aparece un mensaje del tipo: “No se pueden modificar las celdas protegidas.”
  • En caso que quieras dejar el documento cómo estaba en un principio y poder modificar las celdas, ve a Herramientas > Proteger hoja… escribes la contraseña que habías utilizado con anterioridad y pulsas en Aceptar.

Continúa leyendo

Calc dispone de una gran cantidad de funciones estadísticas capaces de realizar complejos cálculos matemáticos.

funciones-estadisticaEstas son algunas de las más usadas:
  • CONTAR(valor1; valor2; … valor30): Cuenta el número de celdas que contienen valores numéricos dentro en un grupo de celdas. No se toman en consideración las entradas de texto.
    Ejemplo: =CONTAR(A1:A10) Devuelve el número de celdas que contienen valores numéricos dentro del rango A1:A10.
  • CONTAR.BLANCO(valor1; valor2; … valor30): Cuenta el número de celdas vacías, esto es, que contienen un valor en blanco dentro de un rango específico.
    Ejemplo: =CONTAR.BLANCOA1:A10) Devuelve el número de celdas vacías dentro del rango A1:A10.
  • CONTAR.SI(rango; condición): Cuenta el número de celdas en un rango que cumplen una determinada condición. Ejemplos:
    =CONTAR.SI(A1:A10; “<10”) Devuelve el número de celdas que contienen valores numéricos menores de 10 dentro del rango A1:A10.
    =CONTAR.SI(A1:A10; “hombre”) Devuelve el número de celdas que contienen la palabra “hombre” dentro del rango A1:A10.
    Para contar únicamente los números negativos: =CONTAR.SI(A1:A10;”<0″)

Continúa leyendo

La potencia de Calc permite crear con facilidad todo tipo de formularios y plantillas, en este artículo vamos a ver como diseñar un modelo sencillo de factura.
Una factura es un documento legal que todo profesional, empresario o autónomo está obligado a emitir a la hora de realizar cualquier operación económica. Este documento debe reflejar toda la información necesaria sobre dicha operación.
El modelo que hemos plasmado aquí es de carácter general y puede ser modificado según lo requieran las circunstancias.
factura-simpleComo se puede apreciar hemos reservado un espacio para el anagrama de la empresa, otro para los datos del cliente a quien se factura, otro para los datos de la empresa y uno más para indicar, de forma bien visible, la fecha y el número de factura. A continuación están ubicados los detalles, precios y subtotales. Finalmente, en la parte inferior, hemos habilitado unas celdas para el IVA, el importe total de la factura y la forma de pago.
Los únicos cálculos que hemos realizado son el producto de CANTIDAD x PRECIO en la columna TOTAL, la suma de la columna TOTAL en SUMA, el porcentaje de IVA en IVA y el importe total de la factura en TOTAL FACTURA.
Puedes descargar la plantilla de Calc en este ENLACE.

solver-8Solver (o Solucionador) es una de las herramientas más potentes de que disponemos en Calc.

El algoritmo Solver permite la optimización y asignación eficiente de recursos escasos (tierra, trabajo, capital, capacidad gerencial, etc.), de tal manera que se cumplan las metas deseadas, como son la maximización de los beneficios, o la minimización de los costos.
Solver utiliza el método de la Programación Lineal (LP), es una técnica muy potente de asignación de recursos para resolver problemas para negocios y organizaciones.
En este artículo vamos a ver que no es nada difícil su uso y que nos puede resultar extremadamente útil para resolver funciones complejas.
Lo primero que tenemos que aclarar es: ¿Para qué sirve Solver? ¿Qué hace Solver? Pues bien, Solver es una herramienta usada para hacer cálculos matemáticos complejos, las posibilidades son múltiples y muy variadas, para ver cómo funciona vamos a realizar un ejemplo desarrollando una aplicación que nos resuelva un problema concreto.
Supongamos que un vendedor de productos informáticos desea realizar un pedido para ampliar el stock de determinados productos, los productos que necesita y los precios de cada uno son los siguientes:
  • Placas Base: 90€
  • Microprocesadores: 65€
  • Ventiladores: 12€
Para realizar el pedido dispone de un máximo de 3.000€, ahora bien, hay una limitación en la cantidad mínima que el distribuidor suministra de cada componente, estas cantidades mínimas son las siguientes:
  • Placas Base: pedido mínimo 10 unidades
  • Microprocesadores: pedido mínimo 5 unidades
  • Ventiladores: pedido mínimo 10 unidades

Continúa leyendo

La función matemática SUMA resulta especialmente útil. Su misión, como su nombre indica, es la de sumar todos los valores de un área de celdas, ya sean celdas específicas o las de un rango de celdas. Como para todas las formulas en Calc debemos escribir el signo “=” antes que la función, de esta manera le indicamos al programa que lo que viene a continuación es una fórmula.
suma1

Función matemática SUMA

Para sumar celdas concretas, la sintaxis es:  =SUMA(A1; B3; A2). Este ejemplo lo que hace es sumar las cantidades contenidas en las celdas A1, B3 y A2. Los sumandos deben aparecer separados por “;” y entre paréntesis.
También podemos incluir en la función SUMA cantidades fijas, como por ejemplo: =SUMA(A6; C7; 4). Ahora la función nos devuelve la suma de las cantidades contenidas en A6 y C7 y le suma una cantidad fija, el 4.
Si lo que deseamos es sumar un rango de celdas debemos indicar en la función el comienzo y el final del mismo, separados por el signo “:“. Veamos unos ejemplos:
  Para sumar los datos de una columna: =SUMA(B1:B10), nos suma los datos contenidos en la columna B, empezando en B1 y terminando en B10.
  Para sumar los datos de una fila la fórmula es igual, indicamos el inicio y el final separados por “:”, o sea, =SUMA(A5:C5).
También podemos combinar la suma de celdas sueltas y celdas contenidas en un rango, por ejemplo: =SUMA(B2:B8; C9), esta fórmula nos devuelve la suma de las celdas contenidas entre B2 y B8 y, a continuación, la suma el valor de C9.

En la siguiente imagen se puede apreciar el resultado de los ejemplos anteriores:

suma2

Como se puede apreciar las combinaciones y posibilidades de la función SUMA son múltiples, sólo es cuestión de imaginación y conseguiremos adaptar la fórmula a nuestras necesidades.

 etiquetas1

En Calc, las pestañas son las solapas que aparecen en la parte inferior de las hojas y que, por defecto, se nombran como “Hoja1”, “Hoja2”, “Hoja3”, etc. La forma y el contenido de estas pestañas se puede cambiar a fin de obtener un resultado, estéticamente, más vistoso. Veamos como:
Para empezar, lo primero que podemos hacer es cambiar el nombre de la Pestaña, esto es bien sencillo, basta con hacer doble clic sobre la solapa que deseamos modificar y acto seguido podemos darle el nombre apropiado. Hay que señalar que no se pueden emplear caracteres especiales para los nombres de las Pestañas, sólo podemos usar letras, mayúsculas y minúsculas, y el guión ( – ). También podemos realizar esta misma acción pulsando sobre la Pestaña con el botón derecho del ratón y seleccionando la opción “Cambiar nombre de hoja…”
etiquetas2
Otra acción que podemos realizar es cambiar el color de fondo de las Pestañas. Para ello, hacemos clic con el botón derecho del ratón sobre la Pestaña que deseamos cambiar, nos aparecerá un menú del que elegimos la opción “Color de pestaña…”, ahora nos aparecerá una pequeña ventana en la que podemos seleccionar el color que deseamos para fondo de la Pestaña.
etiquetas3
etiquetas4

Color de la pestaña

Continúa leyendo